How to Allow Default VLAN1 Traffic between Cisco and Juniper

This post is to list out the compatible configuration to allow default VLAN1 traffic between Cisco and Juniper. In this post, let’s assume VLAN1 are used for Switch Management, yes it is bad practice 🙁

Single Connection Between Cisco and Juniper

Cisco
interface GigabitEthernet1/0/14
 description ***Single_conneciton_between_Cisco_Juniper****
 switchport mode trunk

interface Vlan1
 ip address 10.0.0.1 255.255.255.0


ICTFellaCiscoSW01#show interfaces trunk

Port           Mode             Encapsulation  Status        Native vlan
Gi1/0/14       on               802.1q         trunking      1


Port           Vlans allowed on trunk
Gi1/0/14       1-4094


Port           Vlans allowed and active in management domain
Gi1/0/14       1,3-8,10,15,20,30,40,50-52,75,80,99,131,133,191-192,201-206,212-213,223,500-501,503,701


Port           Vlans in spanning tree forwarding state and not pruned
Gi1/0/14       1,3-8,10,15,20,30,40,50-52,75,80,99,131,133,191-192,201-206,212-213,223,500-501,503,701
Juniper

Please define your VLAN 1 as native vlan on the Juniper side:

admin@ICTFellaJuniperSW01# show interfaces | match ge-0/0/13 | display set
set interfaces ge-0/0/13 description Cisco_Juniper_trunk
set interfaces ge-0/0/13 native-vlan-id 1
set interfaces ge-0/0/13 unit 0 family ethernet-switching interface-mode trunk
set interfaces ge-0/0/13 unit 0 family ethernet-switching vlan members all
set interfaces ge-0/0/13 unit 0 family ethernet-switching storm-control default


admin@ICTFellaJuniperSW01# show interfaces irb | display set
set interfaces irb unit 0 family inet address 10.0.0.234/24

{master:0}[edit]
admin@ICTFellaJuniperSW01# show vlans | display set
set vlans default vlan-id 1
set vlans default l3-interface irb.0

LACP between Cisco and Juniper

Cisco
interface TenGigabitEthernet1/1/4
 description LACP_Cisco_Juniper
 switchport mode trunk
 switchport nonegotiate
 channel-protocol lacp
 channel-group 44 mode active

interface TenGigabitEthernet2/1/4
 description LACP_Cisco_Juniper
 switchport mode trunk
 switchport nonegotiate
 channel-protocol lacp
 channel-group 44 mode active

interface Port-channel44
 description LACP_Cisco_Juniper
 switchport mode trunk
 switchport nonegotiate

interface Vlan1
 ip address 10.0.0.1 255.255.255.0


Juniper

Important Note: Please make sure the Device Count for Aggregated Devices are set, otherwise LACP will never work

set chassis aggregated-devices ethernet device-count 64

set interfaces ge-0/1/2 ether-options 802.3ad ae44
set interfaces ge-1/1/2 ether-options 802.3ad ae44

set interfaces ae44 description ***LACP_Cisco_Juniper***
set interfaces ae44 native-vlan-id 1
set interfaces ae44 aggregated-ether-options lacp active
set interfaces ae44 aggregated-ether-options lacp periodic fast
set interfaces ae44 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae44 unit 0 family ethernet-switching vlan members all

admin@ICTFellaJuniperSW01# show interfaces irb | display set
set interfaces irb unit 0 family inet address 10.0.0.234/24

{master:0}[edit]
admin@ICTFellaJuniperSW01# show vlans | display set
set vlans default vlan-id 1
set vlans default l3-interface irb.0

Useful link

https://www.juniper.net/documentation/us/en/software/junos/interfaces-security-devices/topics/topic-map/security-interface-config-lacp.html

https://www.cisco.com/c/en/us/td/docs/ios/12_2sb/feature/guide/gigeth.html

Leave a Comment

Your email address will not be published. Required fields are marked *