This post is about cofiguring Trunk port between Meraki and Cisco Catalyst switch.
Similar “cross-vendor” trunk port configuation from another post:
Standard Trunk Port Configuration
Meraki side
Cisco Side
conf t
!
interface GigabitEthernet1/0/23
description ****Uplink_Meraki_SW01_Port23****
switchport trunk native vlan 4
switchport trunk allowed vlan 1,2,3,4
switchport mode trunk
!
end
wr
LACP Etherchannel Configuration
Meraki Side
Cisco Side
conf t
!
default int gi1/0/23
default int gi1/0/24
!
interface GigabitEthernet1/0/23
description **trunk_LACP**
switchport trunk native vlan 4
switchport trunk allowed vlan 1,2,3,4
switchport mode trunk
channel-group 64 mode active
!
interface GigabitEthernet1/0/24
description **trunk_LACP**
switchport trunk native vlan 4
switchport trunk allowed vlan 1,2,3,4
switchport mode trunk
channel-group 64 mode active
!
interface Port-channel64
description **trunk_LACP**
switchport
switchport trunk native vlan 4
switchport trunk allowed vlan 1,2,3,4
switchport mode trunk
!
end
wr
Useful link
https://documentation.meraki.com/MS/Port_and_VLAN_Configuration/Switch_Ports