How to Configure Cisco Juniper Fortinet EtherChannel LACP

Object

When it is coming to project execution and solution integration, ICT network professionals always have the challenge to interconnect multiple vendors together, it is not difficult but painful to deal with. This article is to show you the typical EtherChannel configuration examples when you try to interconnect them across multiple vendors:

Cisco and Juniper Etherchannel with LACP: Switch to Switch

Cisco Side:

interface Port-channel10
description Trunk test
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate

interface GigabitEthernet1/0/27
description Po10 trunk
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-protocol lacp
channel-group 10 mode active
!
interface GigabitEthernet1/0/28
description Po10 trunk
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-protocol lacp
channel-group 10 mode active

Juniper Side:

Please set up the Chassis aggregation count FIRST, otherwise, it will NEVER work

set chassis aggre device count 64

set interfaces ge-0/0/0 ether-options 802.3ad ae15
set interfaces ge-0/0/1 ether-options 802.3ad ae15

set interfaces ae15 description “to Cisco LACP_ICT Fella”
set interfaces ae15 aggregated-ether-options lacp active
set interfaces ae15 aggregated-ether-options lacp periodic fast
set interfaces ae15 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae15 unit 0 family ethernet-switching vlan members all

Cisco WLC to Juniper EX switch Link Aggregation

Note: This example is to use simple link aggregation WITHOUT LACP enabled

Cisco WLC:

Juniper EX switch:

set chassis aggre device count 64

set interfaces ge-0/0/0 ether-options 802.3ad ae15
set interfaces ge-0/0/1 ether-options 802.3ad ae15

set interfaces ae15 description “to Cisco WLC_ICT Fella”
set interfaces ae15 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae15 unit 0 family ethernet-switching vlan members all

Fortinet Fortigate Firewall to Cisco switch

Fortinet

Go to Network – Interface – Create New – Interface

fortigate-lacp-aggregation
An example of Fortigate LACP Aggregation

You then can create the logical interfaces under the new “Aggregation1” interface and define the VLAN ID etc.

Cisco Side:

Note: This is an example of a Cisco Catalyst 9000 series switch stack.

interface Port-channel8
switchport mode trunk

interface GigabitEthernet1/0/23
switchport mode trunk
channel-group 8 mode active

interface GigabitEthernet2/0/23
switchport mode trunk
channel-group 8 mode active

Useful Links

Cisco WLC aggregation:

https://community.cisco.com/t5/wireless-mobility-documents/lag-link-aggregation/ta-p/3128669#toc-hId-1040690679

Juniper Configuring Aggregated Ethernet Interfaces:

https://www.juniper.net/documentation/us/en/software/junos/interfaces-security-devices/topics/topic-map/security-interface-config-aggregated-ethernet.html

Cisco Link Aggregation Control Protocol (LACP) (802.3ad) for Gigabit Interfaces

https://www.cisco.com/c/en/us/td/docs/ios/12_2sb/feature/guide/gigeth.html

Leave a Comment

Your email address will not be published. Required fields are marked *