This post is about configuring LACP between FS and Cisco Switches.
Environment
* FS Switch end
FS_SW01#sh ver
System description : FS Campus Switch (S5860-20SQ) By FS.COM Inc
System start time : 2022-09-09 02:30:34
System uptime : 5:04:36:52
System hardware version : 1.00
System software version : S5860_FSOS 12.4(1)B0101P1S6, Release(09160217)
System patch number : NA
System serial number : G1xxxxxxxxxx
System boot version : 1.4.17(Master) 1.4.3(Slave)
System rboot version : 1.1.12
* Cisco Switch end
Switch Ports Model SW Version SW Image Mode
------ ----- ----- ---------- ---------- ----
* 1 41 C9300-24P 17.06.03 CAT9K_IOSXE INSTALL
2 41 C9300-24P 17.06.03 CAT9K_IOSXE INSTALL
* 4x 10G connection in between
FS switch configuration
====Change the port speed to 10G as our Cisco 9300 can only support 10G
FS_SW01(config)#interface tf1/0/23
*Aug 11 15:46:04: %PARAM-6-CONFIG_SYNC: (*2/0) Sync'ing the running configuration from the active supervisor.
FS_SW01(config-if-TFGigabitEthernet 1/0/23)#description ***LACP1**
FS_SW01(config-if-TFGigabitEthernet 1/0/23)#port speed-mode 10G
Warning: Ports TF1/0/21, TF1/0/22, TF1/0/23, TF1/0/24 will be set speed mode 10G. Continue? [Y/N]:Y\
FS_SW01(config-if-TFGigabitEthernet 1/0/23)#
FS_SW01(config-if-TFGigabitEthernet 1/0/23)#
FS_SW01(config-if-TFGigabitEthernet 1/0/23)#
FS_SW01(config-if-TFGigabitEthernet 1/0/23)#
FS_SW01(config-if-TFGigabitEthernet 1/0/23)#*Aug 11 15:46:10: %LINK-3-UPDOWN: Interface TFGigabitEthernet 1/0/23, changed state to up.
*Aug 11 15:46:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface TFGigabitEthernet 1/0/23, changed state to up.
*Aug 11 15:46:10: %LINK-3-UPDOWN: Interface TFGigabitEthernet 1/0/24, changed state to up.
*Aug 11 15:46:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface TFGigabitEthernet 1/0/24, changed state to up.
FS_SW01(config-if-TFGigabitEthernet 1/0/23)#
FS_SW01(config-if-TFGigabitEthernet 1/0/23)#
FS_SW01(config-if-TFGigabitEthernet 1/0/23)#interface tf2/0/23
FS_SW01(config-if-TFGigabitEthernet 2/0/23)#description ***LACP1**
FS_SW01(config-if-TFGigabitEthernet 2/0/23)#port speed-mode 10G
Warning: Ports TF2/0/21, TF2/0/22, TF2/0/23, TF2/0/24 will be set speed mode 10G. Continue? [Y/N]:Y
FS_SW01(config-if-TFGigabitEthernet 2/0/23)#
FS_SW01(config-if-TFGigabitEthernet 2/0/23)#
FS_SW01(config-if-TFGigabitEthernet 2/0/23)#*Aug 11 15:46:34: %LINK-3-UPDOWN: Interface TFGigabitEthernet 2/0/23, changed state to up.
e*Aug 11 15:46:34: %LINEPROTO-5-UPDOWN: Line protocol on Interface TFGigabitEthernet 2/0/23, changed state to up.
xit*Aug 11 15:46:34: %LINK-3-UPDOWN: Interface TFGigabitEthernet 2/0/24, changed state to up.
*Aug 11 15:46:34: %LINEPROTO-5-UPDOWN: Line protocol on Interface TFGigabitEthernet 2/0/24, changed state to up.
====Configure the LACP
interface TFGigabitEthernet 1/0/23
port speed-mode 10G
description ***LACP1**
port-group 1 mode active
!
interface TFGigabitEthernet 1/0/24
port speed-mode 10G
description ***LACP1**
port-group 1 mode active
!
interface TFGigabitEthernet 2/0/23
port speed-mode 10G
description ***LACP1**
port-group 1 mode active
!
interface TFGigabitEthernet 2/0/24
port speed-mode 10G
description ***LACP1**
port-group 1 mode active
!
interface AggregatePort 1
description ***LACP1**
switchport mode trunk
Cisco Switch configuration
interface TenGigabitEthernet1/1/7
description ***LACP1**
switchport mode trunk
channel-group 1 mode active
!
interface TenGigabitEthernet1/1/8
description ***LACP1**
switchport mode trunk
channel-group 1 mode active
!
interface TenGigabitEthernet2/1/7
description ***LACP1**
switchport mode trunk
channel-group 1 mode active
!
interface TenGigabitEthernet2/1/8
description ***LACP1**
switchport mode trunk
channel-group 1 mode active
!
interface Port-channel1
description ***LACP1**
switchport mode trunk
LACP status
FS_SW01#sh lacp summary
System Id:32768, 649d.99d1.xxxx
Flags: S - Device is requesting Slow LACPDUs F - Device is requesting Fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.
Aggregate port 1:
Local information:
LACP port Oper Port Port
Port Flags State Priority Key Number State
---------------------------------------------------------------------------
TF1/0/23 SA bndl 32768 0x1 0x17 0x3d
TF1/0/24 SA bndl 32768 0x1 0x18 0x3d
TF2/0/23 SA bndl 32768 0x1 0x39 0x3d
TF2/0/24 SA bndl 32768 0x1 0x3a 0x3d
Cisco_SW01#sh etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
A - formed by Auto LAG
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Te1/1/7(P) Te1/1/8(P)
Te2/1/7(P) Te2/1/8(P)
Cisco_SW01#show int po1
Port-channel1 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 6026.aac2.7ea3 (bia 6026.aac2.7ea3)
Description: ***LACP1**
MTU 1500 bytes, BW 40000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 10Gb/s, link type is auto, media type is N/A
input flow-control is on, output flow-control is unsupported
Members in this channel: Te1/1/7 Te1/1/8 Te2/1/7 Te2/1/8
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:01, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 13000 bits/sec, 10 packets/sec
5 minute output rate 12000 bits/sec, 8 packets/sec
5391196 packets input, 1290326836 bytes, 0 no buffer
Received 417912 broadcasts (338247 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
Useful links
https://www.cisco.com/c/en/us/td/docs/ios/12_2sb/feature/guide/gigeth.html