Object
We recently purchased a couple of FS.com S5810 switches, after some testing, troubleshooting, we get them working and this post is to document the configurations conducted during the process. Configuration examples such as Virtual Switch Link, LACP, DHCP server, etc may help some people if you are struggling. Those Switches’ CLI is very much like Cisco but still slightly different.
Environment
- 2x S5810-48FS, 48-Port 1G SFP L3 fully managed switch
- 2x FS 10Gbps DAC cables and 2x FS 1G Ethernet SFP modules
Stacking
Again instead of reading the lengthy configuration guide, here listed the procedures to configure 2 switches with Virtual Switch Link on Stacking mode
Member 1
FS(config)#switch virtual domain 100
FS(config-vs-domain)#swi
FS(config-vs-domain)#switch 1
FS(config-vs-domain)#swi
FS(config-vs-domain)#switch 1 pri
FS(config-vs-domain)#switch 1 priority 200
FS(config-vs-domain)#switch crc errors 10 times 20
FS(config-vs-domain)#exit
FS(config)#vsl-
FS(config)#vsl-port
FS(config-vsl-port)#port
FS(config-vsl-port)#port-member interface te0/51
FS(config-vsl-port)#port-member interface te0/52
FS(config-vsl-port)#exit
FS(config)#exit
Member 2
FS(config)#switch virtual domain 100
FS(config-vs-domain)#swi
FS(config-vs-domain)#switch 2
FS(config-vs-domain)#swi
FS(config-vs-domain)#switch 2 pri
FS(config-vs-domain)#switch 2 priority 200
FS(config-vs-domain)#switch crc errors 10 times 20
FS(config-vs-domain)#exit
FS(config)#vsl-
FS(config)#vsl-port
FS(config-vsl-port)#port
FS(config-vsl-port)#port-member interface te0/51
FS(config-vsl-port)#port-member interface te0/52
FS(config-vsl-port)#exit
FS(config)#exit
Covert the working mode to “Stacking” mode, then reboot on both switches
FS#switch convert mode virtual
Verify the stacking after reboot
DHCP Configuration
It is ALMOST the same as Cisco Catalyst switches but you need the” Service DHCP” to enable the DHCP service, otherwise, DHCP will never work
service dhcp
ip dhcp excluded-address 192.168.96.129 10.68.96.150
!
ip dhcp pool MGMT
lease 8 0 0
network 192.168.96.128 255.255.255.192
dns-server 1.1.1.1 8.8.8.8
default-router 192.168.96.129
LACP Configuration
interface GigabitEthernet 1/0/48
description SW
port-group 4 mode active
!
interface GigabitEthernet 2/0/48
description SW
port-group 4 mode active
!
interface AggregatePort 4
switchport mode trunk
VLAN, SVI, Interface, Static Route
vlan 102
name Server
!
interface GigabitEthernet 1/0/1
description uplink
switchport mode trunk
!
interface VLAN 102
description Server
ip address 192.168.102.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.96.1
Hostname, Spanning Tree, Authentication, MGMT, Timezone
hostname SW01
!
spanning-tree mode rstp
spanning-tree
!
username admin privilege 15 password 7 xddeddgdsfse24563224334gv
!
enable service web-server http
enable service web-server https
webmaster level 0 username admin password 7 xddeddgdsfse24563224334gv
!
service password-encryption
!
redundancy
!
clock timezone UTC +8 0
!
enable service ssh-server
!
Useful Link
S5810 Product page
https://www.fs.com/au/products/115384.html
S5810 Configuration Guide
https://img-en.fs.com/file/user_manual/s5810-28fs-and-s5810-48fs-switches-configuration-guide.pdf